Changes with PhoneGap 1.5

Earlier this month, PhoneGap 1.5 was released.   There were a lot of enhancements in this release.  However, if you’ve tried to update an existing codebase from PhoneGap 1.4 to 1.5, you may have realized that things look a bit different.   Basically, the entire PhoneGap codebase has migrated from PhoneGap naming to Apache Cordova naming conventions.

Every reference to “PhoneGap” is now “Cordova”.  This includes, but is not necessarily limited to:

  • phonegap.js is now cordova.js
  • The “PhoneGap” object in JavaScript is now “Cordova” – this means every reference to “PhoneGap” should now reference “Cordova”
  • In native code, every PhoneGap class that was prefixed with “PG” is now prefixed with “CDV”; for example, “PGPlugin” is now “CDVPlugin”
  • Documentation that refers to the PhoneGap class may be out of date… just switch the name reference.
  • The “PhoneGap” project template in Xcode is now “Cordova”

This is just a naming convention change as the PhoneGap project is moving to its new identity as Apache Cordova.  However, it is just a name.  Be sure to read this article from the PhoneGap team to understand why the name changed and to understand the relationship between “PhoneGap” and “Cordova”.

As a PhoneGap developer, how you build applications has not changed, and the power of PhoneGap/Cordova has not changed.   You can still create awesome apps with it, and it is still 100% open source.

If you are looking at code that doesn’t work in PhoneGap 1.5, then chances are you need to update to use the new naming conventions.

If you are just getting started, be sure to check out my “Getting Started with PhoneGap” guides on Adobe Developer Connection for both Android and iOS – both of these articles use the new naming conventions.

  • http://simonmacdonald.com Simon MacDonald

    To make matters more confusing the JavaScript object on Android is “cordova” and on iOS it is “Cordova”. When 1.6 is released it will be “cordova” for all platforms.

    • http://www.tricedesigns.com Andrew

      Thanks for the clarification Simon!

  • http://jayengineteam.blogspot.com Kevin Wong

    I tried to convert your PGLowLatencyAudio plugin to 1.5, but it fails. Could you try to show me how to convert it?

    Thanks a lot.

  • Martina

    I also tried to update the PGLowLatencyAudio plugin to 1.5 but couldn’t accomplish it either.

    In Xcode I get errors like “Variable ‘pluginResult’ is uninitialized.

    Is a new build for PGLowLatencyAudio available?

    Thx.