Upcoming Changes with PhoneGap 2.1 & iOS 6

Are you using PhoneGap/Apache Cordova for iOS development?  If so, you’ll definitely want to pay attention to the upcoming PhoneGap 2.1 release. If you haven’t seen it already, be sure to check out Shazron’s post: 11 upcoming changes for Cordova iOS 2.1.  Changes include Automatic Rererecnce Counting (ARC) support, an updated Native-JavaScript bridge, diagnostics, and iOS 6 compatibility support, among other changes.

Wait, what?  Did I just reference “iOS 6 compatibility”?

Yes, there are a few minor issues related to API changes from Apple.  We can’t go into detail about them yet due to Apple’s non-disclosure agreement by which all Apple developers are bound. However, you will want to pay attention to PhoneGap/Cordova 2.1 release, and upgrade accordingly if your application is impacted.  Most existing apps won’t be affected, but a small number may encounter an issue or two.  Be sure to test your apps on the iOS 6 beta to make sure they are ready.  There are workarounds to these issues without having to upgrade to PhoneGap 2.1, but all new apps targeting iOS 6 will definitely want to use PhoneGap 2.1 or newer.

You can check out the Apache Cordova JIRA bug tracker for the 2.1 release to see a bit more of what is involved in the upcoming release.

  • http://lapiz.no alejandro

    phonegap 2.1 will support xcode 4.4?…, i tried phonegap 2.0 in xcode 4.4 and got like one hundred of warnings…

    thanks

    • http://www.tricedesigns.com Andrew

      Yes, it is supported.

  • http://willprater.me will

    I thought this was released when I saw the post. The last rc was about 1 month before release. Are we close?

    • http://www.tricedesigns.com Andrew

      It is close, there have been a few RCs already released, but the final should be any day now. (sorry for the delay responding, it’s been a busy few weeks)

  • http://www.lapiz.no alejandro

    I was going to ask you about the release date of phonegap 2.1, but i think it will come after the release of xcode 4.5, and maybe also some upgrade to xcode 4.5.1 , so around September 12 or maybe a new final stable version phonegap 2.1.1 at the end of the month…. ??

    anyway, one last question…

    setup and start working with xcode 4.5 will be as easy as it was with phonegap 1.8.1 ?

    Thanks for this nice web, is very useful

    • http://www.tricedesigns.com Andrew

      Yes, it will be just as easy. PhoneGap 2.1 should hit any day now… I know its coming very soon.

  • http://aspinsa.com Uday

    We are using phonegap build services(not X-code) to build the IPA.Though the app worked on Phonegap 2.0 build but its no longer working using PhoneGap 2.1.0 on Ipad,Ipod,Iphone. Pleas note that we are not using X-code but default Phonegap build service.Any insights ?
    Can some one shed some light on this as its urgent.Do we need to change any settings or paths etc…?

    Thanks,
    Uday

    • http://www.tricedesigns.com Andrew

      What do you mean by “it is no longer working”? Are you getting any error messages? Can you provide any detail on the issues that you are encountering? You shouldn’t need to change any paths. Are you running into a JavaScript error within your application which is preventing anything from loading?